Re: [ROOT] Impossible to use Root 4.01/04 on Windows XP

From: Rene Brun (Rene.Brun@cern.ch)
Date: Mon Dec 13 2004 - 16:44:05 MET


FX,

You do not have a main program in your example !!

Rene Brun

> GENTIT Francois-Xavier DAPNIA wrote:
> 
> [Image]
> 
> Hello rooters,
> 
> I still have the problem that I described in bug 2562, and it seems that I am
> the only one with this problem. I am working under Windows XP, trying to use
> ROOT 4.01/04 version "Win32gdk". The problem is that none of my programs
> compiled and linked ok, using "make" in a cygwin window, work. When clicking
> on the .exe produced, I get the following message:
> 
> Error in <TWinNTSystem::DynamicPathName>: Win32gdk does not exist in
> .;E:\Applications\extlib\ROOT\v4_01_04\root/bin; C:\WINNT\system32;
> C:\WINNT;C:\WINNT\System32\Wbem; C:\Program Files\Common
> Files\AutodeskShared\;E:\Applications\Dev\VS_7_1\Vc7\bin;E:\Applications\Dev\VS_7_1\Common7\IDE;E:\Applications\rootdev\bin;E:\Applications\extlib\ROOT\v4_01_04\root\bin,
> or has wrong file extension (.dll)
> 
> Notice that the message is strange, since libWin32gdk.dll indeed exists in
> E:\Applications\extlib\ROOT\v4_01_04\root\bin and is not empty.
> 
> The problem occurs also exactly the same if I compile and link the program
> with Visual C++ 7.1
> 
> I have done an almost empty "hello" program which also does not work and I
> join it with this mail. I would be extremely happy if someone could try it.
> Joined with Hello.ZIP is also the file LoaderMessage.txt where the full output
> written at the launch of the program is written.
> 
> I have done the following checks:
> 
> (1) - No problem at all with ROOT 4.00/08
> 
> (2) - ROOT in itself is perfectly working: I have tried .x benchmarks.C and it
> works.
> 
> (3) - I have also tried to compile and link with make in a cygwin window, all
> the ROOT examples in $ROOTSYS/test: everything works ok!!! It is extremely
> irritating that only my programs do not work!!!
> 
> (4) - If instead of clicking twice on hello.exe, I launch ROOT and do
> gSystem.Load("libHello"); everything works ok !!!
> 
> It is the first time I have such a strange problem with ROOT and I am anxious
> of being obliged to stick forever to ROOT 4.00/08. Many many thanks if you can
> help me!
> 
> F.X.Gentit
> 
> DAPNIA/SPP CEA Saclay
> 
> http://gentit.home.cern.ch/gentit/
> 
> 
> 
>                 Name: Hello.ZIP
>    Hello.ZIP    Type: Zip Compressed Data (application/x-zip-compressed)
>             Encoding: base64
> 
>                    Name: image001.jpg
>    image001.jpg    Type: JPEG Image (image/jpeg)
>                Encoding: base64



This archive was generated by hypermail 2b29 : Sun Jan 02 2005 - 05:50:10 MET