Re: make debian in 4.04/02

From: Christian Holm Christensen <cholm_at_nbi.dk>
Date: Wed, 15 Jun 2005 11:00:11 +0200


Hi Chris,

On Tue, 2005-06-14 at 12:16 -0700, Chris Roat wrote:
> Hi Christian,
>
> I think there might be more to it than that. When doing as you say, I find
>
> 1) it requires libafterimage-dev and
> 2) it claims the wrong source code version (presumably from the changelog)
>
> I can fix 2) by adding a stanza to the changelog. It seems just
> commenting out the --disable-builtin-afterimage from the
> build/package/debian/rules file doesn't change whether or not it
> requires libafterimage-dev. Should I have or not have
> libafterimage-dev installed?

To build the Debian packages of versions of ROOT earlier than 5.01/01, do

         cvs -d :pserver:cvs_at_root.cern.ch:/user/cvs login
         Password: cvs
         cvs -d :pserver:cvs_at_root.cern.ch:/user/cvs export \
                 -d root-4.04.02 -r v4-04-02 root
         cd root-4.04.02
         vi build/packages/debian/rules
         [Take out the `--disable-builtin-afterimage' from the `configure command line]
	 vi build/packages/lib/makebuilddepends.sh 
	 [Change the line that has `*asimage', so that it doesn't echo anything]
	 dch -c build/package/debian/changelog -v 4.01.01 "New upstream version"
         make debian

All this (and more) has been fixed in the HEAD of CVS. I'm sorry I didn't list the last two steps the first time around. It wasn't clear to me exactly what had been fixed in CVS.

Yours,

-- 
 ___  |  Christian Holm Christensen 
  |_| |  -------------------------------------------------------------
    | |  Address: Sankt Hansgade 23, 1. th.  Phone:  (+45) 35 35 96 91
     _|           DK-2200 Copenhagen N       Cell:   (+45) 24 61 85 91
    _|            Denmark                    Office: (+45) 353  25 404
 ____|   Email:   cholm_at_nbi.dk               Web:    www.nbi.dk/~cholm
 | |
Received on Wed Jun 15 2005 - 11:00:21 MEST

This archive was generated by hypermail 2.2.0 : Tue Jan 02 2007 - 14:45:09 MET