5.08: warning message for TCanvas saved with 4.04

From: Alexander Bürger <buerger_at_iskp.uni-bonn.de>
Date: Mon, 06 Feb 2006 13:38:32 +0100


Dear ROOTers,

after switching from ROOT version 4.04 to 5.08 I get the following message every time I load files that were created by c1->Print("...root") with the old version:

Attaching file ...root as _file0...
Warning in <TStreamerInfo::BuildCheck>:

         The StreamerInfo of class TPad read from file ..root
         has the same version (=8) as the active class but a different 
checksum.
         You should update the version to ClassDef(TPad,9).
         Do not try to write objects with the current class definition,
         the files will not be readable.

Is it possible to get rid of this message?

Thanks for your help,

Alexander Received on Mon Feb 06 2006 - 13:38:37 MET

This archive was generated by hypermail 2.2.0 : Mon Jan 01 2007 - 16:31:57 MET